0x01 gns3 配置路由表

引入

本篇内容有:

1.配置静态路由

2.使用RIP配置动态路由

开始

建立路由表的三种途径:

1.直连路由——直接连到路由器上的网络

2.静态路由——管理员手工构建路由表

3.动态路由——路由器之间动态学习到的路由表

注:在特权模式下输入write即可将配置保存下来

配置直连(静态)路由

准备工作——配置各个路由器接口的IP

拓扑如下:

/*
 *配置R1的f0/0接口
 */
 //进入配置模式
 configure terminal

 //进入f0/0接口
 interface f0/0

 //配置ip为192.168.1.1,子网掩码为255.255.255.0
 ip address 192.168.1.1 255.255.255.0

 //开启该接口
 no shutdown

 //查看当前接口ip(需退回到特权模式,即R1#的状态)
 show running-config

 /*
 *配置R2,R3的步骤类似,这里不再赘述
 */

配置目的:R1能ping通R3

配置R1->R3的路由(在R1下配置)

实现的功能:让包从R1的f0/0接口送到R3中

命令格式:ip route [目标网络号] [子网掩码] [发送数据的接口]

//配置直连路由
ip route 10.10.10.0 255.255.255.0 f0/0

//查看路由状态
show ip route

仅凭这次配置是无法使R1 ping通R3的

虽然R1可以成功向R3发送ICMP包,但R1无法收到R3向R1返回的ICMP包

所以我们还需要在R3下配置路由

配置R3->R1的路由(在R3下配置)

实现功能:让包从R3的f0/1接口送到R1中

//配置直连路由
ip route 192.168.1.0 255.255.255.0 f0/1

//查看路由状态
show ip route

这时就可以使R1 ping通R3了

注:还可以将命令最后的接口换为IP,含义为:

将包发送给该IP指定的接口

之后,包就会被该IP指定的路由器进行处理了

配置默认路由

默认路由只可存在于末梢网络中(即在本例中只有R1、R3能配置)

//配置R1的默认路由
ip route 0.0.0.0 0.0.0.0 192.168.1.2

配置黑洞路由

黑洞路由:可以让路由器将无用的包扔到里面(相当于垃圾桶)

//配置黑洞路由(注意接口需设置为null0)
ip route [network-address] [subnet-mask] null0

删除路由配置

//删除123.123.123.0 255.255.255.0 f0/0这条路由
no ip route 123.123.123.0 255.255.255.0 f0/0

配置动态路由

拓扑图如下:

准备工作

这里不再赘述路由器IP的配置

配置PC1的操作如下:

//将路由器当做电脑来使用
no ip routing

//配置ip
interface f0/0
ip address 192.168.1.10 255.255.255.0
no shutdown

//配置网关
ip default-gateway 192.168.2.254

配置PC2的操作同理

配置RIP

/*
 *R1的配置
 */

//进入配置模式
configure terminal

//进入RIP
router rip

//【必敲】选择RIP版本(最好选择2)
verison 2

//【必敲】关闭路由自动汇总
no auto-summary

//配置宣告RIP(配置为路由各个接口的网络号即可)
network 12.1.1.0
network 192.168.1.0

/*
 *按相同的方法配置R2、R3即可
 */

配置完之后,PC1即可ping通PC2


如果我的文章能帮到您的话我会很开心.如需转载记得注明出处:)
目录